User Reminder

Here my mods and history gets moved when validated and released to the phpbb.com MODDB

Re: User Reminder

Postby J.P. » Fri Sep 05, 2008 2:01 pm

Thanks it's works for your mod.
I have the same problem for phpbb_gallery_0_3_1.
There they use
Code: Select all
'auth' => 'acl_a_board', 'cat' => array('PHPBB_GALLERY')),

Will that works too when i change it to
Code: Select all
'auth' => acl_a_user, 'cat' => array('PHPBB_GALLERY')),


Update

I have try it on my test site and it's works too.
J.P.
Newbie/Neuling
 
Posts: 5
Joined: Wed Jul 16, 2008 10:00 pm
Location: Netherlands, Groningen

Re: User Reminder

Postby lefty » Fri Sep 05, 2008 6:26 pm

great :)
i think i will definitely add separate permissions in a future version
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby kevin1 » Wed Sep 24, 2008 12:40 pm

I think I could really use this MOD, so I have installed it, and everything seemed to go fine.

I am trying to set up "Protected Users" but my boards usernames have spaces in them (i.e. "John Smith"). When I submit the usernames, the MOD takes the space out, so username isn't correct. Is there a way around this? I have tried %20 and using quotes around the name without success.

Thanks.
kevin1
Newbie/Neuling
 
Posts: 3
Joined: Wed Sep 24, 2008 12:33 pm
Location: Ontario, Canada

Re: User Reminder

Postby lefty » Wed Sep 24, 2008 5:27 pm

Hi Kevin,
did you apply the fix as well?

For the protected users, it is not the username but their user_id that is needed. if you dont know the id, you can use the find member link ;)
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby kevin1 » Wed Sep 24, 2008 10:43 pm

I am still a little new to phpbb. I am not sure what you mean by user_id.

My message board members log in using their full name (i.e. "John Smith") as their username. This is the information in the username field that comes up when you "Find a member". The only other thing I know is the id number like http://domainname.com/messageboard/memb ... rofile&u=2 where u=2 is my number.

I have applied the fix from user_reminder_101fix.zip.
kevin1
Newbie/Neuling
 
Posts: 3
Joined: Wed Sep 24, 2008 12:33 pm
Location: Ontario, Canada

Re: User Reminder

Postby lefty » Wed Sep 24, 2008 10:49 pm

kevin1 wrote:where u=2 is my number.

2 would in that case be the user_id. ;)
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby kevin1 » Thu Sep 25, 2008 7:22 pm

Thank you. Does this also work for groups? like...g=5 where I put 5 in the protected users list? Is there documentation somewhere that I missed?
kevin1
Newbie/Neuling
 
Posts: 3
Joined: Wed Sep 24, 2008 12:33 pm
Location: Ontario, Canada

Re: User Reminder

Postby lefty » Thu Sep 25, 2008 8:11 pm

no, it does not work with group id's.

I thought I was rather clear in the description of the fields in the ACP : :wink:
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

A problem with my installation(s)

Postby Andrea Gaddini » Mon Sep 29, 2008 9:23 pm

Dear Lefty,

I run 3 separate PHPbb Forums (all ver 3.02) at the Agency for Public Health where I work here in Rome. I am the Admin for all of them. Unfortunately the engineer whom I asked to install your useful mod on all the three forums probably did something wrong, and now all three forums are totally stuck. The bad thing is that on the very day of the install he had to leave for two weeks and he is the only that can access the server... too bad.

Now, here's what I get.

On the first forum (http://www.asplazio.it/forum/eugate_forum/index.php) I can see the board index and login, but if I try to access a non-empty forum, I get:


Fatal error: Call to undefined function get_formatted_filesize() in /usr/local/apache2/htdocs/eugate_forum/includes/functions_content.php on line 837

If I try to access the ACP as Admin, I get:

Fatal error: Call to undefined function get_formatted_filesize() in /usr/local/apache2/htdocs/eugate_forum/includes/acp/acp_main.php on line 322
_______________________________________________________________

On a second, more populated forum (http://www.asplazio.it/forum/promo_forum/index.php), if I login and access any forum (they all are populated here), I get:

General Error
SQL ERROR [ mysql4 ]

Unknown column 's.session_forum_id' in 'where clause' [1054]

SQL

SELECT COUNT(DISTINCT s.session_ip) as num_guests FROM phpbb_sessions s WHERE s.session_user_id = 1 AND s.session_time >= 1222740360 AND s.session_forum_id = 38

BACKTRACE


FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions.php
LINE: 3160
CALL: dbal_mysql->sql_query()

FILE: includes/functions.php
LINE: 3193
CALL: obtain_guest_count()

FILE: includes/functions.php
LINE: 3385
CALL: obtain_users_online()

FILE: viewforum.php
LINE: 136
CALL: page_header()


On this second forum I can access the ACP, however.

___________________________________________________

Now the third forum (http://www.asplazio.it/forum/sisp_forum/index.php).

The message here seems identical to the one shown second Forum:


General Error
SQL ERROR [ mysql4 ]

Unknown column 's.session_forum_id' in 'where clause' [1054]

SQL

SELECT COUNT(DISTINCT s.session_ip) as num_guests FROM phpbb_sessions s WHERE s.session_user_id = 1 AND s.session_time >= 1222741080 AND s.session_forum_id = 13

BACKTRACE


FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions.php
LINE: 3160
CALL: dbal_mysql->sql_query()

FILE: includes/functions.php
LINE: 3193
CALL: obtain_guest_count()

FILE: includes/functions.php
LINE: 3385
CALL: obtain_users_online()

FILE: viewforum.php
LINE: 136
CALL: page_header()


Forgot to mention that before logging in on these last two forums I get a different message when trying to access any forum (actually, it could be a localized and non-verbose version of the previous one):

Errore Generale
SQL ERROR [ mysql4 ]

Unknown column 's.session_forum_id' in 'where clause' [1054]

Si è verificato un errore SQL richiamando questa pagina. Contatta un amministratore se il problema persiste.
_________________________________________________

Now Lefty, I'm sure the engineer did something wrong, but I would really like to be able to help him put things back in the right place as soon as he comes back... can't afford keeping those forums closed. Any clues? I will greatly appreciate your help.

Many thanks, regards, Andrea Gaddini
Andrea Gaddini
Newbie/Neuling
 
Posts: 4
Joined: Mon Sep 29, 2008 8:34 pm

Re: User Reminder

Postby lefty » Mon Sep 29, 2008 9:55 pm

Dear Andrea,
wow, that sure does not look right.... Are you sure this is caused by teh installation of my mod? These error messages do not really refer to any of the areas my mod touches. to be honest, there are very little edits to make to install this mod but there actually seems to be a field missing in one of the tables in the database (session_forum_id).

without any access, this is not really easy to fix as i dont know what has been installed so far and if there were any custom changes made.

there is noone else who has any ftp access at all or access to the database so you can at least add the session_forum_id field in the database?
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby Andrea Gaddini » Mon Sep 29, 2008 10:09 pm

Well, yes Lefty. No other action was performed on the server side besides installing the mod, as far as I know. Actually, the mod seemed to be working in the beginning, apart from the fact that the Forum language had to be set to English - with Italian you couldn't load the mod page in the ACP. I didn't experiment anything, I just checked that the mod was accessible from the ACP and saw the options whithout modifying anything. So I said OK, install the mod on the other two Forums. The problem arised when, as I said, I tried to access some topic in the forum...

I'm tryng to reinstall the mod on another forum (the fourth!) which is located to a server I can access, and hope I can find some solutions. But... do you mean that the missing field in the MySQL table cannot be related in any way to your mod? That really worries me...

Anyway, thanks for trying, as I said I'll really appreciate if you happen to come up with some idea.

Best, Andrea
Andrea Gaddini
Newbie/Neuling
 
Posts: 4
Joined: Mon Sep 29, 2008 8:34 pm

Re: User Reminder

Postby lefty » Mon Sep 29, 2008 10:26 pm

the error message refers to a missing field in the database. if you had some kind of access, it would not be too difficult to readd that field to the database but without the access i would not know how to add it.
Andrea Gaddini wrote:with Italian you couldn't load the mod page in the ACP.

for it to work in italian, the language files would have to be copied ot the correct folder.

Andrea Gaddini wrote:But... do you mean that the missing field in the MySQL table cannot be related in any way to your mod? That really worries me...

yes, i do not think that could be caused by my mod.

do you know if the person that installed the mod has got a backup of your boards and your database?
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby Andrea Gaddini » Mon Sep 29, 2008 11:32 pm

Yes Lefty, I believe backups are being made regularly. But then, those should be automatic backups of this special server which hosts the website and the forums, not the backups made through the forum itself.

Well, I hope it will be okay.

By the way, I just installed your mod now in a newly installed copy of PHPbb on an accessible server, and it runs smoothly at this time.

Lastly, what is the fix you mention in your posts supposed to do? Should I be loading that? (the copy of your mod I have was downloaded from PHPbb a week ago).

Thanks again, will let you know anyway. Andrea
Andrea Gaddini
Newbie/Neuling
 
Posts: 4
Joined: Mon Sep 29, 2008 8:34 pm

Re: User Reminder

Postby lefty » Tue Sep 30, 2008 12:01 am

yes, the fix still needs to be applied, it is not included in the original download.
it's just a matter of replacing a couple of files but it is necessary to do this step.

as for the other boards, i can only imagine that something went wrong with backing up the data at some stage.

Should be fixable tho :)
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby ScrapbookSupplies » Sat Nov 15, 2008 12:58 am

It installed perfectly - I love your mods Lefty, and they are all so useful too! I hardly ever pass one up because I can use all of them and they are put together so well.

:cheer:
ScrapbookSupplies
Forum Member
 
Posts: 14
Joined: Wed Jul 09, 2008 8:42 pm

Re: User Reminder

Postby lefty » Sat Nov 15, 2008 5:51 pm

Thanks very much for the kind words Jeanne :hug:
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby hsn » Fri Nov 28, 2008 9:53 am

I've implemented this mod on http://www.pcduniya.com. Whenever i want to add it in ACP User Reminder module there is no sub-module to be added. Please help me in this regard.


HSN
hsn
Newbie/Neuling
 
Posts: 3
Joined: Fri Nov 28, 2008 9:14 am

Re: User Reminder

Postby hsn » Fri Nov 28, 2008 10:01 am

ohhh. I forgot to mention that i'm on windows server 2k3 r2 hosting.
hsn
Newbie/Neuling
 
Posts: 3
Joined: Fri Nov 28, 2008 9:14 am

Re: User Reminder

Postby lefty » Fri Nov 28, 2008 12:14 pm

i am not familiar with windows servers but you may wish to run the install file mentioned in the first post. it will set up the sql and modules for you.

let me know if you still have issues after that.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby hsn » Fri Nov 28, 2008 5:29 pm

whenever i call install file which you posted later it give me this error,


General Error
Language file info_acp_user_reminder.php couldn't be opened.
hsn
Newbie/Neuling
 
Posts: 3
Joined: Fri Nov 28, 2008 9:14 am

Re: User Reminder

Postby lefty » Fri Nov 28, 2008 7:29 pm

did you upload all the files that were in the root folder?

if you use different languages you will need to copy the folders from the root/language/en folder to the other folders as well.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby My10 » Mon Dec 01, 2008 11:24 pm

Thanks lefty on this mod :thumbsup:

Is it possible to build one more option: notify users "xy" days after the last writing? I will be really grateful. :hug:
My10
Newbie/Neuling
 
Posts: 1
Joined: Mon Dec 01, 2008 11:14 pm

Re: User Reminder

Postby lefty » Tue Dec 02, 2008 12:06 am

Hi, right now, there is no plan to add anything further as i have plenty non-validated mods that i still need to look at.

once i have done those, i might have another look at this one.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby lefty » Sun Jan 04, 2009 11:05 pm

i was just asked how to add a .MODS category in the acp.

now, normally, this is already included in the default phpbb package.

should you, for whatever reason, have deleted it ect. here is how you can manually enter it.

note: Make sure you use ACP_CAT_DOT_MODS as the category name, don't use anything else.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: User Reminder

Postby lefty » Mon Jan 05, 2009 11:24 pm

The following should be changed as otherwise no automatic reminders are sent after a change of year.
open index.php
find
Code: Select all
if ( $config['user_reminder_last_auto_run'] < $check_time)


and replace with

Code: Select all
if ( $config['user_reminder_last_auto_run'] != $check_time)
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

PreviousNext

Return to [3.0.x] MOD Database Releases

Who is online

Users browsing this forum: No registered users and 2 guests

cron