Avatar of poster on Index and Viewforum 1.2.1a

Here my mods and history gets moved when validated and released to the phpbb.com MODDB

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby coolheart » Tue Jun 15, 2010 9:55 am

Hi Lefty!

I'm trying to install you faboulous mod but I'm havins some "I'm totally noob on this" issues.

The first of all, and this is a totally noob question, what sql i have to edit to add the sql lines what appears on your install instructions for this mod?

And the second: I've installed the mod according your install instructions (except the sql modification) and I have this error:

Parse error: syntax error, unexpected ';', expecting ')' in /home/admin1/public_html/forum/includes/functions_display.php on line 498

Can you help me!?

Thank you very much!
coolheart
Newbie/Neuling
 
Posts: 6
Joined: Tue Jun 15, 2010 9:50 am

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby coolheart » Tue Jun 15, 2010 10:06 am

Hahaha!!!

Ok I've answered myself to the first question. But I need help with the parse error.

Thanks!
coolheart
Newbie/Neuling
 
Posts: 6
Joined: Tue Jun 15, 2010 9:50 am

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Tue Jun 15, 2010 7:56 pm

looks like a wrong edit.
could you post some of the code around that line 498. 20 lines above and below should hopefully do it.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby coolheart » Wed Jun 16, 2010 9:20 am

Ok! This is the code between lines 470 and 561

Code: Select all
$s_subforums_list = array();   
foreach ($subforums_list as $subforum)   
{   
   $s_subforums_list[] = '<a href="' . $subforum['link'] . '" class="subforum ' . (($subforum['unread']) ? 'unread' : 'read') . '" title="' . (($subforum['unread']) ? $user->lang['NEW_POSTS'] : $user->lang['NO_NEW_POSTS']) . '">' . $subforum['name'] . '</a>';
}   
$s_subforums_list = (string) implode(', ', $s_subforums_list);   
$catless = ($row['parent_id'] == $root_data['forum_id']) ? true : false;   

if ($row['forum_type'] != FORUM_LINK)   
{   
   $u_viewforum = append_sid("{$phpbb_root_path}viewforum.$phpEx", 'f=' . $row['forum_id']);
}      
else      
{      
   // If the forum is a link and we count redirects we need to visit it   
   // If the forum is having a password or no read access we do not expose the link, but instead handle it in viewforum   
   if (($row['forum_flags'] & FORUM_FLAG_LINK_TRACK) || $row['forum_password'] || !$auth->acl_get('f_read', $forum_id))   
   {   
      $u_viewforum = append_sid("{$phpbb_root_path}viewforum.$phpEx", 'f=' . $row['forum_id']);
   }   
   else   
   {   
      $u_viewforum = $row['forum_link'];
   }   
}      

$template->assign_block_vars('forumrow', array(      
   'S_IS_CAT'         => false,
$avatar_max_dimensions = $avatar_width = $avatar_height = '';            
if ( !empty($row['forum_last_poster_avatar']) )            
{            
   $avatar_max_dimensions = 40; // here you can change the max-width you would like to have the avatars displayed         

   if ( $row['forum_last_poster_avatar_width'] >= $row['forum_last_poster_avatar_height'] )         
   {         
      $avatar_width = ( $row['forum_last_poster_avatar_width'] > $avatar_max_dimensions ) ? $avatar_max_dimensions : $row['forum_last_poster_avatar_width'] ;      
      $avatar_height = ( $avatar_width == $avatar_max_dimensions ) ? round($avatar_max_dimensions / $row['forum_last_poster_avatar_width'] * $row['forum_last_poster_avatar_height']) : $row['forum_last_poster_avatar_height'] ;      
   }         
   else          
   {         
      $avatar_height = ( $row['forum_last_poster_avatar_height'] > $avatar_max_dimensions ) ? $avatar_max_dimensions : $row['forum_last_poster_avatar_height'] ;      
      $avatar_width = ( $avatar_height == $avatar_max_dimensions ) ? round($avatar_max_dimensions / $row['forum_last_poster_avatar_height'] * $row['forum_last_poster_avatar_width']) : $row['forum_last_poster_avatar_width'] ;      
   }         
}               

   'S_NO_CAT'         => $catless && !$last_catless,   
   'S_IS_LINK'         => ($row['forum_type'] == FORUM_LINK) ? true : false,   
   'S_UNREAD_FORUM'   => $forum_unread,         
   'S_LOCKED_FORUM'   => ($row['forum_status'] == ITEM_LOCKED) ? true : false,         
   'S_LIST_SUBFORUMS'   => ($row['display_subforum_list']) ? true : false,         
   'S_SUBFORUMS'      => (sizeof($subforums_list)) ? true : false,      
   'S_FEED_ENABLED'   => ($config['feed_forum'] && !phpbb_optionget(FORUM_OPTION_FEED_EXCLUDE, $row['forum_options'])) ? true : false,         

   'FORUM_ID'            => $row['forum_id'],
   'FORUM_NAME'         => $row['forum_name'],   
   'FORUM_DESC'         => generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']),   
   'TOPICS'            => $row['forum_topics'],
   $l_post_click_count      => $post_click_count,      
   'FORUM_FOLDER_IMG'      => $user->img($folder_image, $folder_alt),      
   'FORUM_FOLDER_IMG_SRC'   => $user->img($folder_image, $folder_alt, false, '', 'src'),         
   'FORUM_FOLDER_IMG_ALT'   => isset($user->lang[$folder_alt]) ? $user->lang[$folder_alt] : '',         
   'FORUM_IMAGE'         => ($row['forum_image']) ? '<img src="' . $phpbb_root_path . $row['forum_image'] . '" alt="' . $user->lang[$folder_alt] . '" />' : '',   
   'FORUM_IMAGE_SRC'      => ($row['forum_image']) ? $phpbb_root_path . $row['forum_image'] : '',      
   'LAST_POST_SUBJECT'      => censor_text($last_post_subject),      
   //for NV ALTT            
   'ALTT_LINK_NAME_SHORT'      => censor_text($altt_link_name_short),      
   'ALTT_LINK_NAME'         => censor_text($altt_link_name),   
   'ALTT_STYLE_BOLD'         => $altt_style_bold,   
   'ALTT_STYLE_ITALIC'         => $altt_style_italic,   
   'ALTT_STYLE_ADV'         => $altt_style_adv,   
   'ALTT_STYLE_ADV2'         => $altt_style_adv2,   
   'U_ALTT_LINK'            => $altt_link_url,
   'LAST_POST_TIME'      => $last_post_time,      
   'LAST_POSTER'         => get_username_string('username', $row['forum_last_poster_id'], $row['forum_last_poster_name'], $row['forum_last_poster_colour']),   
   'LAST_POSTER_COLOUR'   => get_username_string('colour', $row['forum_last_poster_id'], $row['forum_last_poster_name'], $row['forum_last_poster_colour']),         
   'LAST_POSTER_FULL'      => get_username_string('full', $row['forum_last_poster_id'], $row['forum_last_poster_name'], $row['forum_last_poster_colour']),      
   'LAST_POSTER_AVATAR'   => ($config['enable_avatar_index']) ? get_user_avatar($row['forum_last_poster_avatar'], $row['forum_last_poster_avatar_type'], $avatar_width, $avatar_height) : false,         
   'LAST_POSTER_AVATAR_MARGIN'   => ( $avatar_width == $avatar_max_dimensions ) ? 5 : ( $avatar_max_dimensions - $avatar_width + 5 ),         
   'AVATAR_WIDTH'         => $avatar_max_dimensions,   

   'MODERATORS'         => $moderators_list,   
   'SUBFORUMS'            => $s_subforums_list,

   'L_SUBFORUM_STR'      => $l_subforums,      
   'L_FORUM_FOLDER_ALT'   => $folder_alt,         
   'L_MODERATOR_STR'      => $l_moderator,      

   'U_UNAPPROVED_TOPICS'   => ($row['forum_id_unapproved_topics']) ? append_sid("{$phpbb_root_path}mcp.$phpEx", 'i=queue&amp;mode=unapproved_topics&amp;f=' . $row['forum_id_unapproved_topics']) : '',         
   'U_VIEWFORUM'      => $u_viewforum,      
   'U_LAST_POSTER'      => get_username_string('profile', $row['forum_last_poster_id'], $row['forum_last_poster_name'], $row['forum_last_poster_colour']),      
   'U_LAST_POST'      => $last_post_url)      
);            


Regards!
coolheart
Newbie/Neuling
 
Posts: 6
Joined: Tue Jun 15, 2010 9:50 am

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Wed Jun 16, 2010 6:59 pm

the install instruction said ADD, BEFORE and not ADD, AFTER ;)
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby coolheart » Thu Jun 17, 2010 9:08 am

D'ouch!

This is what happens when you are not paying atention to what you are doing! hahaha!!

Thank for your help. I fixed it and all goes right!

Thanks!!!
coolheart
Newbie/Neuling
 
Posts: 6
Joined: Tue Jun 15, 2010 9:50 am

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby wideglide » Tue Aug 03, 2010 3:07 pm

Hello,
in your mod DIY instructions you say:

Once done, make sure to delete avatar_update.php and language/en/avatar_update.php.

The last file,language/en/avatar_update.php,Ive found and deleted.
But the first file mentioned,avatar_update.php,I can't find.
Where can I find it?
Thank you!
wideglide
Newbie/Neuling
 
Posts: 8
Joined: Tue May 11, 2010 2:07 pm

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Tue Aug 03, 2010 10:04 pm

hi, it should be in your root folder
root/avatar_update.php
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby wideglide » Wed Aug 04, 2010 6:49 am

Lefty,
thank you for answering.
I just had a look again,I gave "refresh" and there the file was!
Thank you.
wideglide
Newbie/Neuling
 
Posts: 8
Joined: Tue May 11, 2010 2:07 pm

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Wed Aug 04, 2010 8:43 pm

hi wideglide, you are welcome :)
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby gpgiuit » Thu Sep 16, 2010 11:52 pm

hello thanks to your great mod that I have seen on another forum :cheer:
I have a problem and I don't understand where I was wrong.
I have a modified template, supermario, so maybe problem is template???
I have previously installed ultimate seo url and gym sitemap
my site forum [dot] giocattolissimi [dot] it
I pray you please I see a white page after the mod.
:newcry2:

I have phpbb 3.0.7pl1
gpgiuit
Newbie/Neuling
 
Posts: 1
Joined: Thu Sep 16, 2010 11:49 pm

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Fri Sep 17, 2010 8:31 pm

hi, white pages are normally indicators of suppressed error messages.

have a look on your server if you can find an error log or check with your host.

it could well be that an edit was not at the right place and therefore you get a php error.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby javimoso » Sat Nov 13, 2010 7:38 pm

Hello,,,

I have a doubt if you could guide me a bit,,,

I want to know the changes to the index addition forums and also leave the avatar when you do a search, the results of the search, it would be possible,,,

Sorry for my English,, Spanish I,,,,

Greetings
javimoso
Newbie/Neuling
 
Posts: 1
Joined: Sat Nov 13, 2010 7:35 pm

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Sat Nov 13, 2010 8:52 pm

hi,
probably in the search.php but i havent looked at the phpbb code in about a year so i have forgotten a lot where stuff is.

sorry i cant be more precise.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby mcsnoopy » Fri Dec 10, 2010 5:10 pm

hi :)... i have installed your mod in my phpBB forum, and it's great but i'have two small problems...

(Excuse my poor english is not my first language :)
Image

as u can see, there is no problem where a user use normal register way and choose his avatar (for sample davide's message)

but if u login with fbconnect034 problems begining (for sample ele's message) she has not her facebook picture in viewforum.php but in viewtopics.php and in the profile she has it...

this is the first problem... the second problem is user who register in the normal way and haven't avatar haven't the default one...

thanks for the attenctions :)
mcsnoopy
Newbie/Neuling
 
Posts: 1
Joined: Fri Dec 10, 2010 4:58 pm

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Tue Dec 14, 2010 9:15 pm

hi, sorry for the delay.

fbconnect034, is that a mod that or a new feature of 3.0.8?
same with default avatar, is this a mod you are using?
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby FRvNR » Wed Dec 15, 2010 2:31 pm

lefty wrote:fbconnect034, is that a mod that or a new feature of 3.0.8?

facebook connect 0.3.4 -> s.h.
ist wohl von [ABD] wieder auf Beta gesetzt worden
„Die Menschen müssen lernen wieder zu sehen, was sie anschauen.
Sie müssen ihr Pferd fühlen, um es begreifen zu können.“

Tom Dorrance, 1910 - 2003
FRvNR
Forum Member
 
Posts: 14
Joined: Sun Oct 25, 2009 6:07 pm
Location: Geldern / Germany

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby wondwosen » Tue Jan 11, 2011 1:06 pm

Dear,

Do you have a plan to make this mod working on AutoMod?

Regards,
wondwosen
Newbie/Neuling
 
Posts: 1
Joined: Tue Jan 11, 2011 1:03 pm

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Tue Jan 11, 2011 8:48 pm

hi, it worked fine with automod on 3.0.8 when i tried it a few weeks ago.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby Motobaka » Tue Mar 01, 2011 5:27 am

Hello there Lefty.
I have installed the mod and it worked perfectly until I added the default avatars.
I have read this thread and found the solution to some of my problems but further intents on fixing the other problems have now left me somehow in a worst situation.
Image

This seems to be working correctly but when you select a forum:
Image

The avatars in a red circle show the same avatar in different dimensions at the topic author.
The avatar in blue is missing. (It might be a size thing)
The avatars in green are the default avatars and are shown a lot bigger.

If you look at the second avatar on the last topic column you can see that the nick has the avatar that is missing on the blue circle.

Someone ventured to offer a possible solution but that does seem to distortion the image, the proposed solution is here: http://www.phpbb.com/community/viewtopic.php?f=69&t=1369535&hilit=universal+no+avatar&start=75

Previously you said to do this:
http://www.phpbb.com/community/viewtopic.php?f=69&t=1369535&hilit=universal+no+avatar&start=30#p9055405

But that seems to only help on the index, is there something else i could try?

Thanks in advance, great mod!

Edit: forgot to give a link to the forum: www.poquer833.com
Motobaka
Newbie/Neuling
 
Posts: 3
Joined: Tue Mar 01, 2011 5:09 am

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Tue Mar 01, 2011 7:03 pm

can you please let me know what mod you use for your default avatars?

also, it would probably easier to revert to the situation before you made any changes unless you know exactly what ti is you changed.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby Motobaka » Wed Mar 02, 2011 2:06 am

To change the default avatars I did this:

Open: includes/functions_display.php
Code: Select all
if (empty($avatar) || !$avatar_type)
   {
      return '';


Then inline find:
Code: Select all
return '';


and replace with:

Code: Select all
return '<img src="images/avatars/no_avatar.gif" alt="' . ((!empty($user->lang[$alt])) ? $user->lang[$alt] : $alt) . '" />';


I found all of this here:
http://www.modphpbb3.com/viewtopic.php?f=23&t=391






I've replaced this line in Viewforum.php:


Code: Select all
'TOPIC_AUTHOR_AVATAR'      => ($config['enable_avatar_index']) ? get_user_avatar($row['topic_first_poster_avatar'], $row['topic_first_poster_avatar_type'], $topic_first_poster_avatar_width, $topic_first_poster_avatar_height) : false,


with this line:


Code: Select all
'TOPIC_AUTHOR_AVATAR'      => ($config['enable_avatar_index']) ? get_user_avatar($row['topic_first_poster_avatar'], $row['topic_first_poster_avatar_type'], 40, 40) : false,



Then changed it back to how it was.

This is how it looks now:
Code: Select all
'TOPIC_AUTHOR_AVATAR'      => ($config['enable_avatar_index']) ? get_user_avatar($row['topic_first_poster_avatar'], $row['topic_first_poster_avatar_type'], $topic_first_poster_avatar_width, $topic_last_poster_avatar_height) : false,


I also made this change:
Code: Select all
$avatar_img = $avatar_max_dimensions = $topic_last_poster_avatar_height = $topic_last_poster_avatar_width = $topic_first_poster_avatar_width = $topic_first_poster_avatar_height = 40;


In includes/functions_display.php I made this change:
Code: Select all
$avatar_max_dimensions = $avatar_width = $avatar_height = 40;


And finaly I replaced a line whit this:
Code: Select all
return '<img src="images/avatars/no_avatar.png" ' . (($avatar_width) ? ' width="' . $avatar_width . '" height="' . $avatar_height . '"' : '' ) . ' alt="' . ((!empty($user->lang[$alt])) ? $user->lang[$alt] : $alt) . '" />';
Motobaka
Newbie/Neuling
 
Posts: 3
Joined: Tue Mar 01, 2011 5:09 am

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby lefty » Thu Mar 03, 2011 8:41 pm

i will have to have a look at some time to see if i find a solution.

as you already found out, by default, those edits would not be compatible.
lefty aka The Heikze! :eyebrowe:

Heiko Carstens
http://www.lefty74.com

Would you like me to install one of my mods for you? Read here for details
lefty
Abschlussklasse R10c
 
Posts: 1357
Joined: Mon Feb 06, 2006 1:20 am
Location: Den Haag - NL

Re: Avatar of poster on Index and Viewforum 1.2.1a

Postby Motobaka » Thu Mar 03, 2011 9:34 pm

lefty wrote:i will have to have a look at some time to see if i find a solution.

as you already found out, by default, those edits would not be compatible.



Thank you i really apreciate your time :D
Motobaka
Newbie/Neuling
 
Posts: 3
Joined: Tue Mar 01, 2011 5:09 am

Avtar Index View Forum - Forumlist / forum body help

Postby mike » Wed Mar 09, 2011 8:58 pm

Your Directions: styles/prosilver/template/forumlist_body.html

Your Code: Find
Code: Select all
<dd class="posts">{forumrow.POSTS} <dfn>{L_POSTS}</dfn></dd>
               <dd class="lastpost"><span>


In line find:
Code: Select all
<dd class="lastpost">


In line add after:
Code: Select all
<!-- IF forumrow.LAST_POSTER_AVATAR --><div style="float: left; padding-top: 0px; margin-left: 5px; margin-right: {forumrow.LAST_POSTER_AVATAR_MARGIN}px;">{forumrow.LAST_POSTER_AVATAR}</div><!-- ENDIF -->

--------------------------------------------------------------------------------------------------------------------------------

My forumlist_body looks like this:

Code: Select all
<!-- DEFINE $CA_FORUMLIST = '1' -->
<div class="cpojer-links"><!-- BEGIN forumrow -->
   <!-- IF (forumrow.S_IS_CAT and not forumrow.S_FIRST_ROW) or forumrow.S_NO_CAT -->
      </table>
      {$CA_BLOCK_END}
      <br />
   <!-- ENDIF -->

   <!-- IF forumrow.S_IS_CAT or forumrow.S_FIRST_ROW or forumrow.S_NO_CAT -->
       {$CA_BLOCK_START}
      {$CA_CAP2_START}<!-- IF forumrow.S_IS_CAT --><i><h4 class="simple"><a href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a></h4></i><!-- ELSE -->{L_FORUM}<!-- ENDIF -->{$CA_CAP2_END}
                <p class="trigger" align="right"><img src="/images/collapse.png" alt="collapse" title="collapse" /></p><div class="toggle_button"><div class="block"><table class="tablebg" cellspacing="{$CA_SPACING}" width="100%"></div></div>
      <tr>
         <th colspan="2">&nbsp;{L_FORUM}&nbsp;</th>
         <th width="50">&nbsp;{L_TOPICS}&nbsp;</th>
         <th width="50">&nbsp;{L_POSTS}&nbsp;</th>
         <th width="175">&nbsp;{L_LAST_POST}&nbsp;</th>
      </tr>
   <!-- ENDIF -->

   
   <!-- IF not forumrow.S_IS_CAT -->
      <!-- IF forumrow.S_IS_LINK -->
         <tr>
            <td class="row1" width="31" align="center">{forumrow.FORUM_FOLDER_IMG}</td>
            <td class="row1">
               <!-- IF forumrow.FORUM_IMAGE or (S_ENABLE_FEEDS and forumrow.S_FEED_ENABLED) -->
                  <table border="0" cellspacing="0" cellpadding="0" width="100%"><tr>
                  <!-- IF forumrow.FORUM_IMAGE -->
                            <td valign="middle" style="padding-{S_CONTENT_FLOW_END}: 5px;">{forumrow.FORUM_IMAGE}</td>
                  <!-- ENDIF -->
                  <td width="100%" valign="middle">
               <!-- ENDIF -->
               <a class="forumlink" href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a>
               <p class="forumdesc">{forumrow.FORUM_DESC}</p>
               <!-- IF S_ENABLE_FEEDS and forumrow.S_FEED_ENABLED -->
                   </td>
                        <td valign="top" style="padding-{S_CONTENT_FLOW_BEGIN}: 2px;"><a title="{L_FEED} - {forumrow.FORUM_NAME}" href="{U_FEED}?f={forumrow.FORUM_ID}"><img src="{T_THEME_PATH}/images/feed.gif" alt="{L_FEED} - {forumrow.FORUM_NAME}" /></a>
               <!-- ENDIF -->
               <!-- IF forumrow.FORUM_IMAGE or (S_ENABLE_FEEDS and forumrow.S_FEED_ENABLED) --></td></tr></table><!-- ENDIF -->
            </td>
            <!-- IF forumrow.CLICKS -->
               <td class="row2" colspan="3" align="center"><span class="genmed">{L_REDIRECTS}: {forumrow.CLICKS}</span></td>
            <!-- ELSE -->
               <td class="row2" colspan="3" align="center">&nbsp;</td>
            <!-- ENDIF -->
         </tr>
      <!-- ELSE -->
      <tr>
         <td class="row1" width="31" align="center">{forumrow.FORUM_FOLDER_IMG}</td>
         <td class="row1">
            <!-- IF forumrow.FORUM_IMAGE or (S_ENABLE_FEEDS and forumrow.S_FEED_ENABLED) -->
               <table border="0" cellspacing="0" cellpadding="0" width="100%"><tr>
                    <!-- IF forumrow.FORUM_IMAGE -->
                   <td valign="middle" style="padding-{S_CONTENT_FLOW_END}: 5px;">{forumrow.FORUM_IMAGE}</td>
                 <!-- ENDIF -->
                    <td width="100%" valign="middle">
            <!-- ENDIF -->
            <a class="forumlink<!-- IF forumrow.S_UNREAD_FORUM --> link-new<!-- ENDIF -->" href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a>
            <p class="forumdesc">{forumrow.FORUM_DESC}</p>
            <!-- IF forumrow.MODERATORS -->
               <p class="forumdesc"><strong>{forumrow.L_MODERATOR_STR}:</strong> {forumrow.MODERATORS}</p>
            <!-- ENDIF -->
            <!-- IF forumrow.SUBFORUMS and forumrow.S_LIST_SUBFORUMS -->
               <p class="forumdesc"><strong>{forumrow.L_SUBFORUM_STR}</strong> {forumrow.SUBFORUMS}</p>
            <!-- ENDIF -->
                <!-- IF S_ENABLE_FEEDS and forumrow.S_FEED_ENABLED -->
                    </td>
                    <td valign="top" style="padding-{S_CONTENT_FLOW_BEGIN}: 2px;"><a title="{L_FEED} - {forumrow.FORUM_NAME}" href="{U_FEED}?f={forumrow.FORUM_ID}"><img src="{T_THEME_PATH}/images/feed.gif" alt="{L_FEED} - {forumrow.FORUM_NAME}" /></a>
                <!-- ENDIF -->
                <!-- IF forumrow.FORUM_IMAGE or (S_ENABLE_FEEDS and forumrow.S_FEED_ENABLED) --></td></tr></table><!-- ENDIF -->
         </td>
         <td class="row2" align="center"><p class="topicdetails">{forumrow.TOPICS}</p></td>
         <td class="row2" align="center"><p class="topicdetails">{forumrow.POSTS}</p></td>
         <td class="row2" align="center" nowrap="nowrap">
            <!-- IF forumrow.LAST_POST_TIME --><div id="text"><p><!-- IF S_ALTT_ACTIVE --><!-- IF forumrow.ALTT_LINK_NAME_SHORT --><a <!-- IF ALTT_STYLE -->style="{ALTT_STYLE}"<!-- ENDIF --> href="{forumrow.U_ALTT_LINK}" title="{forumrow.ALTT_LINK_NAME}">{forumrow.ALTT_LINK_NAME_SHORT}</a><!-- ELSE -->{L_ALTT_PROTECTED}<!-- ENDIF --><br /><!-- ENDIF --></p></div>

               <p class="topicdetails"><!-- IF forumrow.U_UNAPPROVED_TOPICS --><a href="{forumrow.U_UNAPPROVED_TOPICS}">{UNAPPROVED_IMG}</a>&nbsp;<!-- ENDIF -->{forumrow.LAST_POST_TIME}</p>
               <p class="topicdetails">{forumrow.LAST_POSTER_FULL}
                  <!-- IF not S_IS_BOT --><a href="{forumrow.U_LAST_POST}">{LAST_POST_IMG}</a><!-- ENDIF -->
               </p>
            <!-- ELSE -->
               <p class="topicdetails">{L_NO_POSTS}</p>
            <!-- ENDIF -->
         </td>
      </tr>
      <!-- ENDIF -->
   <!-- ENDIF -->
   <!-- IF forumrow.S_LAST_ROW -->
      <!-- IF not S_IS_BOT and U_MARK_FORUMS -->
      <tr>
         <td colspan="5" class="cat" align="center">
            <a href="{U_MARK_FORUMS}">{L_MARK_FORUMS_READ}</a>
         </td>
      </tr>
      <!-- ENDIF -->
      </table>
      {$CA_BLOCK_END}
   <!-- ENDIF -->
<!-- BEGINELSE -->
{$CA_CAP2_START}{L_MESSAGE}{$CA_CAP2_END}
<table class="tablebg" cellspacing="{$CA_SPACING}" width="100%">
<tr>
   <td class="row1" colspan="5" align="center" style="padding: 25px 5px;"><p class="gensmall">{L_NO_FORUMS}</p></td>
</tr>
</table>
<!-- END forumrow --></div>
mike
Forum Member
 
Posts: 11
Joined: Tue Mar 08, 2011 7:34 am

PreviousNext

Return to [3.0.x] MOD Database Releases

Who is online

Users browsing this forum: No registered users and 2 guests

cron